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Boson NetSim Overview
The Boson NetSim® Network Simulator®, which includes the Boson Router Simulator®, is unique compared 
to all others on the market because of the functionality it supports and its features. NetSim utilizes Boson’s 
proprietary Network Simulator, Router Simulator®, and EROUTER® software technologies, along with 
the Boson Virtual Packet Technology® engine, to create individual packets. These packets are routed and 
switched through the simulated network, allowing NetSim to build an appropriate virtual routing table and 
simulate true networking. Other simulation products on the market do not support this level of functionality.

NetSim is a Windows®-based product that simulates a wide variety of Cisco® routers, including the 2500 
series, 2600 series, 2800 series, and 3600 series routers, as well as the Cisco Catalyst 1900 series, 2900 
series, and 3500 series switches. NetSim supports multiple routing protocols, including RIP, IGRP, EIGRP, 
BGP, and OSPF. It supports different LAN/WAN protocols, including PPP/CHAP, ISDN, and Frame Relay. 
The labs in NetSim require only the devices and functionality included with NetSim—they do not require 
access to any external router or switch hardware. NetSim supports many, but not all, of the IOS commands 
available on a physical router or switch. All the commands referenced in the available labs are supported 
by NetSim. The labs included in this book have been selected as companions to the Boson Curriculum. 
However, you can perform any labs that are unlocked for additional practice. 

Achieving Cisco CCENT®, CCNA®, or CCNP® certification is the goal of many people who use this 
product. The Boson NetSim covers not only the SWITCH, TSHOOT, and ROUTE certifications but also 
the ICND1, ICND2, and CCNA certifications, among others. The included labs guide you through the 
configuration of routers, switches, and workstations in a variety of scenarios. Installed labs are made 
available (unlocked) depending on the activation key used to activate the product. All labs are downloaded 
and kept up to date after installation regardless of the activation key used. 

Activation keys unlock labs and increase the number of available commands. Beginning with the Demo 
version of NetSim, the command set is limited to those necessary to perform the steps in the lab. For 
example, if you start your studies with a CCENT activation key, you will have the command set and labs 
available that are necessary to study for that exam. When you are ready to study for either the CCNA or 
CCNP exam, you will need to purchase a new activation key and then activate with the new CCNA or CCNP 
activation key; then, more labs and a larger command set become available. 

A small lock icon ( ) is displayed next to unavailable labs. Higher-level activation keys allow you to work 
through all labs unlocked by lower-level activation keys. All labs included with NetSim are unlocked when a 
CCNP-level activation key is used; courseware labs are unlocked with the appropriate activation key.

After you load and complete an unlocked lab, you can use the grading function in NetSim to grade the lab 
so that you can determine whether you completed it correctly (click Lab > Grade Lab). As you progress 
through the labs, you will master the skills needed to pass the simulation questions in the Cisco certification 
exams. NetSim has the ability to guide and grade, and using it for practice can actually be more helpful than 
using real routers and switches. NetSim allows you to gain experience without requiring you to purchase 
expensive equipment.

The Boson NetSim can be used for additional purposes other than only working through labs. The included 
full version of the NetMap tool allows you to practice designing and planning a network. This tool’s 
functionality goes beyond that of most tools because, once you have created a network topology, you can 
actually create the router configurations that are going to be used, save those configurations, and practice 
using them on simulated devices.
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Routing protocol implementation is one of the more challenging tasks you may encounter. Troubleshooting 
a production network can be a frustrating experience. Fortunately, you can create a virtual copy of your 
network topology by using the Boson NetMap and troubleshoot the problems without interfering with your 
production network. Although you can use NetSim as an aid in troubleshooting, you should not rely only on 
NetSim to make decisions about a production network, because NetSim is not designed to test real networks. 
Instead, it is a tool that you can use to study for Cisco certification.

In summary, Boson NetSim is a flexible and powerful product that can help you become certified and, 
in some cases, can be used to create a simulation of the topology of your corporate network and help you 
practice troubleshooting without using devices on the production network.

Using NetSim to Prepare for Your Certification
By incorporating NetSim as part of your process of achieving a Cisco certification, you can learn and master 
the skills necessary to help you successfully complete your certification track. The purpose of NetSim is to 
help you with the practical, hands-on portion of your education and to ensure that you not only understand 
the concepts of routing but can actually configure and implement routing on Cisco devices.

Mastering Cisco networking involves two fundamental tasks: 

Learn the theory of routers and switches.
Gain the hands-on experience of implementing that theory by configuring the devices in a network and 
testing them in a lab.

Self-studying for a Cisco certification can be a daunting task. The amount of information a CCNA candidate 
is required to know and the skills that candidate is required to possess are quite extensive. To begin learning 
the theory of configuring a network, you can find a good reference book or listen to an instructor. But 
a reference book might not be enough. The book will not give you the practical, hands-on experience of 
routing and switching that you can learn from NetSim—experience that will help you build on the theoretical 
knowledge you learned from the reference book.

Real equipment gives you the ability to practice on actual routers and switches, but it also is a very costly 
way to practice and leaves a lot of room for error. The Boson NetSim, on the other hand, is an excellent tool 
to help you prepare for the CCNA (www.boson.com/certification/CCNA) and CCNP  
(www.boson.com/certification/CCNP) exams. NetSim simulates the behavior of a network and does not 
just return preprogrammed responses to expected command inputs. It allows you to create virtual packets 
and virtual frames that will be routed and switched through the simulated network. Aside from physically 
plugging in the cables and listening to the fan noise, your experience with the simulated network will be 
much the same as your experience with a fully functional lab rack without the expense of the hardware. 
NetSim will enable you to practice various configurations and master helpful skills.

Once you feel you have mastered the theory and the practical labs, you can test your knowledge by using the 
Boson ExSim-Max practice exam products available at the ExSim-Max home page  
(www.boson.com/exsim-max-practice-exams). Boson ExSim-Max practice exam products can include 
complex multiple-choice questions, drag-and-drop questions, Boson NetSimX simulation questions, and 
trouble tickets that simulate the questions you will see on the live exam.

1.
2.

www.boson.com/certification/CCNA
www.boson.com/certification/CCNP
www.boson.com/exsim-max-practice-exams
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The Boson NetSim Network Simulator is the most comprehensive product on the market for learning how to 
configure a Cisco router. The Boson NetSim will not only help you become certified, it will actually help you 
learn and understand how to configure routers, switches, and networks.

For more information on how to use NetSim, please read the NetSim User Manual by clicking Help > Users 
Manual from within NetSim or by downloading the User Manual from the following link:

http://www.boson.com/Files/Support/NetSim-10-User-Manual.pdf

Using NetSim at Home – Single User
The following steps are for installation and activation for a single user license and should not be performed 
on a classroom workstation.

Downloading and Installing NetSim
You can download NetSim from the Boson.com downloads page (account required): 

http://www.boson.com/download

You must have a Boson account to download the NetSim Demo. To create a free account, visit the Boson 
Online Account page (https://www.boson.com/account/default.aspx) and enter a valid e-mail address to begin 
creating an account.

You should download the NetSim installer to your computer before beginning the installation. It is 
recommended that you disable antivirus and firewall software while installing and activating NetSim and 
then reactivate when the installation is complete. Double-click the downloaded installation file to begin the 
installation, and perform the steps described in the prompts during installation.

Activating NetSim – Single User
When you first open NetSim, you will be presented with a Product Activation dialog box. Enter your e-mail 
address and password, and then click Next. On the next screen, select whether you want to activate NetSim 
in Online Mode (recommended method) or Offline Mode. Click Next. Then type the activation key; this 
information should be in the purchase receipt you received via e-mail, or you can find the receipt online on 
your Boson Online Account page (https://www.boson.com/account/default.aspx). If you are a student, you 
might receive this information from your learning institution or your instructor. You must have an active 
Internet connection in order to activate the full version of NetSim.

After a successful activation, the lab packs will be updated and NetSim will be ready for you to use. Installed 
labs are made available (unlocked) depending on the activation key used to activate the product. A small lock 
icon ( ) is displayed next to unavailable labs. To make additional labs available, you will need to purchase a 
new activation key and then reactivate with the new activation key; then, more labs and a larger command set 
become available.

If you have not purchased an activation key for NetSim or if you received an activation key from your 
learning institution, you will not be able to activate the full version of NetSim on your personal computer. 
However, you can choose to continue in Demo mode. When you are running the Demo mode, only the demo 
lab and a limited set of commands are functional. To purchase the full version of NetSim, visit the About 
NetSim page (www.boson.com/support/netsim-support-topics) of the Boson website.

http://www.boson.com/Files/Support/NetSim-10-User-Manual.pdf
http://www.boson.com/download
https://www.boson.com/account/default.aspx
https://www.boson.com/account/default.aspx
www.boson.com/support/netsim-support-topics
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Loading a Lab
You can open NetSim from the shortcut installed during the download or from the Start menu by clicking 
Boson Software > Boson NetSim > Boson NetSim. If you are a student using NetSim at a learning 
institution, you should launch NetSim from the Start menu by clicking Boson Software > Boson NetSim > 
Boson NetSim LS Client. This will enable you to configure NetSim to authenticate with the Boson NetSim 
License Server.

1. You can begin a preloaded Boson NetSim lab by performing one of the following tasks:
 • On the navigation pane, click Labs; then, on the Standard tab of the Labs panel, double-click the lab  

 you want to open.
 • Click to highlight a lab on the Labs pane, then click Lab > Load lab.
 • Select a lab from the list of Recent Labs or Saved Labs on the Home pane.
2. After you have loaded a lab, click the Lab Instructions tab and read through the lab instructions.
3. From the Devices drop-down menu on the Consoles section, select the device(s) that you need to 

configure in order to complete the lab and follow the steps in the lab. You can also select the device you 
want to configure by clicking the NetMap tab, right-clicking the device, and selecting Configure in 
Simulator.

4. When you have completed the lab, click Lab > Grade Lab to ensure that you have completed it 
successfully.

5. You can choose to save your single device configuration or multiple device configurations by selecting 
the appropriate option in the File menu. 

You might also be instructed to open labs from a custom lab pack. If any custom labs are available, they will 
be on the Custom tab of the Labs pane. To open a custom lab, double-click the lab you want to load.

Accessing NetSim in the Classroom – Boson LS Client
If you are using NetSim in the classroom, it should already be installed on your classroom workstation. You 
should perform the following steps to configure NetSim to access the NetSim License Server.

As a student using NetSim at a learning institution, you should launch NetSim from the Start menu by 
clicking Boson Software > Boson NetSim > Boson NetSim LS Client. This will enable you to configure 
NetSim to authenticate with the Boson NetSim License Server.

Configuring NetSim to Authenticate with the Boson NetSim License Server
Note: Prior to using the Boson NetSim Client, you might need to associate your Boson.com account 
information with Boson NetSim. If you receive an activation key from your learning institution, activate 
Boson NetSim on your personal computer after creating a Boson.com account. Your network administrator/
instructor can then add you as an authorized user to the license server application. You may need to provide 
your learning institution with the e-mail address associated with your Boson.com account. You should not 
give your Boson.com account password to your instructor or learning institution. Your instructor will assign 
you a password that he or she has configured on the License Server, which you will need for step 3. 

1. Run the Boson NetSim LS Client by clicking Start > All Programs > Boson Software > Boson  
NetSim > Boson NetSim LS Client.
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2. In the Boson NetSim - License Agreement dialog box, select Yes to agree to the Authorized User 
Agreement. If you do not agree to the Authorized User Agreement, you will not be able to use the Boson 
NetSim client.

3. Your instructor will provide you with the settings you need to enter in the Boson NetSim Client dialog 
box. Enter the IP address (or computer name if the client computer and the license server are on a 
Windows-based network) and the port number of the computer running the NetSim License Server 
software. Enter the user name/password combination for authentication to the server. The user name will 
be the login information you used to establish an account with Boson.com, or the user name provided by 
your instructor. Enter the password assigned to you by your network administrator/instructor.

 

4. Select either CCNA or CCNP from the Version drop-down list; the version you select must match the 
version that is the current license type configured on the NetSim License Server.

 

5. Click Connect.
6. If a license is available on the license server, the Continue button will be enabled. Click the Continue 

button to start using the Boson NetSim.

For additional information on using Boson NetSim, please consult the Boson NetSim User Manual on Boson.
com or click Help > Users Manual.
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Loading a Lab
1. You can begin a preloaded Boson NetSim lab by performing one of the following tasks:
 • Expand the Labs panel; then, on the Standard tab of the Labs panel, double-click the lab you want  

 to open.
 • Click to highlight a lab, then click Lab > Load Lab.
 • Select a lab from the list of Recent Labs or Saved Labs on the Home pane.
2. After you have loaded a lab, click the Lab Instructions tab and read through the lab instructions.
3. From the Devices drop-down menu on the Consoles section, select the device(s) that you need to 

configure in order to complete the lab and follow the steps in the lab. You can also select the device you 
want to configure by clicking the NetMap tab, right-clicking the device, and selecting Configure in 
Simulator.

4. When you have completed the lab, click Lab > Grade Lab to ensure that you have completed it 
successfully.

5. You can choose to save your single device configuration or multiple device configurations by selecting 
the appropriate option in the File menu.

You might also be instructed to open labs from a custom lab pack. If any custom labs are available, they will 
be on the Custom tab of the Labs pane. To open a custom lab, double-click the lab you want to load.
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Lab 1.1 – Device Management
To perform this lab in the Boson NetSim, please download the necessary files (refer to your purchase receipt 
for the download link), navigate to the appropriate lab in the lab menu in NetSim, and load the lab. You can 
then accomplish the tasks below.

Objective
This lab corresponds to ICND2 Module 1: Cisco Device Management, of Boson’s CCNA Curriculum. In this 
lab, you will learn basic device management techniques including how to save and load router configurations 
from a Trivial File Transfer Protocol (TFTP) server and how to modify the configuration register.

Lab Topology
The topology diagram below represents the NetMap in the Simulator:

Fa0/3
Switch1

Fa0/0 Fa0/0
Fa0/1 Fa0/2Router1 Router2

PC1

The commands you will need to perform the tasks in this lab, along with their syntax and descriptions, are 
shown in the Command Summary table below:

Command Summary
Command Description

configure terminal enters global configuration mode from privileged EXEC mode
config-register value changes configuration register settings
copy running-config {startup-config 
| tftp | device:filename}

copies a device’s running configuration file to another destination

copy tftp {running-config | startup-
config | device:filename}

copies a file from a TFTP server to another destination

enable enters privileged EXEC mode
end ends and exits configuration mode
exit exits one level in the menu structure
hostname host-name sets the device name
show running-config displays the active configuration file
show tftp-configs is used in NetSim to display a list of files copied using TFTP and 

stored on a PC
show version displays hardware platform and software versions

Lab ID: ICND2.0214A021.1.1
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The IP addresses and subnet masks used in this lab are shown in the tables below:

IP Addresses
Device Interface IP Address Subnet Mask

Router1 FastEthernet 0/0 24.37.2.1 255.255.255.0
Router2 FastEthernet 0/0 24.37.2.2 255.255.255.0

Device IP Address Subnet Mask Default Gateway
PC1 24.37.2.252 255.255.255.0 24.37.2.1

Lab Tasks
Task 1: Save a Configuration to a TFTP Server
This task involves saving the current router configuration to the TFTP server.
1. On Router2, copy the running configuration to the TFTP server on PC1. 

2. When prompted for the address or name of the TFTP server, provide PC1’s IP address (24.37.2.252), 
press the Enter key, and then provide the name of the configuration file that will be stored on PC1. 
Name the configuration file router2_config. After you press Enter, the router will take a few seconds 
to establish the connection; then you will see it copy the configuration file.

3. On PC1, issue the show tftp-configs command in order to display the configurations that are stored on 
the TFTP server. You should see the configuration you just saved. 
 
Note: The show tftp-configs command does not work on real PCs; it works only in NetSim.

Task 2: Load a Configuration from a TFTP Server
This task involves loading the configuration from the TFTP server onto Router2. Perform the following steps 
on Router2.
1. Change the host name of the router to Bad_Router.

2. Copy the configuration you stored on the TFTP server into the running configuration.

3. When the router prompts you for a name or an IP address, enter the IP address of the TFTP server 
(24.37.2.252).

4. Enter the name of the configuration file (router2_config) that should be obtained from the TFTP 
server.

5. After the configuration is copied to Router2, what do you observe?  ____________________________   
 __________________________________________________________________________________
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Task 3: Modify the Configuration Register
This task involves changing how Router1 boots. Perform the following steps on Router1.
1. View the current configuration register settings for Router1.

2. Modify the configuration register to configure the device to boot to a rommon> prompt. 

3. Verify that the configuration register setting for Router1 will be applied on reload.

4. Copy the running configuration to the startup configuration file.

Once you have completed this lab, be sure to check your work by using the grading function. You can 
do so by clicking the Grade Lab icon ( ) in the toolbar or by pressing Ctrl+G.
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Lab Solutions
Task 1: Save a Configuration to a TFTP Server
You might need to upgrade IOS on a Cisco router or switch when you need additional features that are not 
available in the version of IOS that you are currently using. Before you can upgrade IOS, you must configure 
a TFTP server at a network location that can be accessed by the router or switch. The TFTP server can be run 
from any supported device on the network as long as the router or switch to be upgraded can connect to the 
device. In this lab, the TFTP server has been configured for you.
1. On Router2, issue the following commands to copy the running configuration to the TFTP server on 

PC1: 
 
Router2>enable 
Router2#copy running-config tftp

2. When prompted for the address or name of the TFTP server, provide PC1’s IP address, press Enter, and 
then provide the name of the configuration file that will be stored on PC1. Name the configuration file 
router2_config. After you press Enter, the router will take a few seconds to establish the connection; 
then you will see it copy the configuration file. Sample output is below: 
 
Address or name of remote host[]? 24.37.2.252 
Destination filename [temp.rtr]? router2_config 
!!!!!

3. On PC1, issue the show tftp-configs command in order to display the configurations that are stored on 
the TFTP server. You should see the configuration you just saved. Sample output from PC1 is below: 
 
C:>show tftp-configs 
 
    Filename             File Size  
 
    router2_config       2481 bytes 
 
Note: The show tftp-configs command does not work on real PCs; it works only in NetSim.

Task 2: Load a Configuration from a TFTP Server
1. On Router2, issue the following commands to change the host name of the router to Bad_Router: 

 
Router2#configure terminal 
Router2(config)#hostname Bad_Router

2. On Router2, issue the following commands to copy the configuration you stored on the TFTP server 
into the running configuration: 
 
Bad_Router(config)#end 
Bad_Router#copy tftp running-config
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3. When Router2 prompts you for a name or an IP address, enter the IP address of the TFTP server: 
 
Address or name of remote host[]? 24.37.2.252

4. When prompted, enter the name of the configuration file that should be obtained from the TFTP server: 
 
Source filename[]? router2_config

5. The router will download the configuration and load it into the running configuration. You can 
verify that the load was successful because the host name will be restored to what it was when the 
configuration was saved.  
 
Router2#

Task 3: Modify the Configuration Register
1. On Router1, issue the show version command to view the current configuration register settings. The 

configuration register is currently set to 0x2102, which is the default. Sample output is below: 
 
Router1>enable 
Router1#show version 
 
Boson Operating Simulation Software 
BOSS (tm) C2800 Software (C2800-Enterprise), Version 12.3, RELEASE SOFTWARE 
Copyright (c) 1998-2013 by Boson Software, Inc. 
 
BOSS ROM: System Bootstrap, Version 12.3, RELEASE SOFTWARE 
Router Uptime Is 0 days, 1 hour, 52 minutes 
System restarted by power-on 
System image file is ““flash:c2800-enterprise.12.2.boss””. booted via flash 
2 Fast Ethernet/IEEE 802.3 interface(s) 
2 Serial network interface(s) 
 
32K bytes of simulated non-volatile configuration memory. 
8192K bytes of simulated System flash (Read/Write) 
 
Configuration register is 0x2102

2. By default, when a Cisco device is unable to locate a valid Cisco IOS image in flash memory during 
the boot process, it will attempt to locate a valid IOS image on a TFTP server on the local network. 
If it cannot locate a TFTP server, it will enter ROM monitor (ROMmon) mode. When a router 
enters ROMmon mode, the rommon> prompt will be displayed instead of the standard prompt that is 
displayed on devices that are properly configured. The device will then load a limited version of the 
IOS from ROM. On Router1, issue the following commands to modify the configuration register to set 
the device to boot to a rommon> prompt: 
 
Router1#configure terminal 
Router1(config)#config-register 0x2120
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3. Issue the show version command to view the configuration register settings for Router1. The 
configuration register will be configured to 0x2120 on the next reload. Sample output from Router1 is 
below: 
 
Router1(config)#end 
Router1#show version 
 
Boson Operating Simulation Software 
BOSS (tm) C2800 Software (C2800-Enterprise), Version 12.3, RELEASE SOFTWARE 
Copyright (c) 1998-2013 by Boson Software, Inc. 
 
BOSS ROM: System Bootstrap, Version 12.3, RELEASE SOFTWARE 
Router Uptime Is 0 days, 1 hour, 52 minutes 
System restarted by power-on 
System image file is ““flash:c2800-enterprise.12.2.boss””. booted via flash 
2 Fast Ethernet/IEEE 802.3 interface(s) 
2 Serial network interface(s) 
 
32K bytes of simulated non-volatile configuration memory. 
8192K bytes of simulated System flash (Read/Write) 
 
Configuration register is 0x2102 (will be 0x2120 on next reload)

4. On Router1, issue the copy running-config startup-config command to copy the running 
configuration to the startup configuration file. On a real router, you could then reboot the device to 
ROMmon mode. ROM does not contain a full version of the Cisco IOS. The boot image loaded from 
ROM will enable you to download a valid IOS image from a specific TFTP server. This process is not 
currently supported in NetSim.
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Sample Configuration Scripts
Router1 Router2

Router1#show running-config
Building configuration...
Current configuration : 689 bytes
!
Version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
ip subnet-zero
!
ip cef
no ip domain-lookup
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FastEthernet0/0
 ip address 24.37.2.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Router2#show running-config
Building configuration...
Current configuration : 689 bytes
!
Version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
ip subnet-zero
!
ip cef
no ip domain-lookup
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FastEthernet0/0
 ip address 24.37.2.2 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end



Certification Candidates

Boson Software’s ExSim-Max practice exams are designed to simulate the complete exam experience. 
These practice exams have been written by in-house authors who have over 30 years combined 
experience writing practice exams. ExSim-Max is designed to simulate the live exam, including topics 
covered, question types, question difficulty, and time allowed, so you know what to expect. To learn 
more about ExSim-Max practice exams, please visit www.boson.com/exsim-max-practice-exams or 
contact Boson Software.

Organizational and Volume Customers

Boson Software’s outstanding IT training tools serve the skill development needs of organizations such 
as colleges, technical training educators, corporations, and governmental agencies. If your organization 
would like to inquire about volume opportunities and discounts, please contact Boson Software at 
orgsales@boson.com.

Contact Information

E-Mail:  support@boson.com
Phone:  ���-333-EXAM (3926)
  61�-��9-0121
Fax:  61�-��9-0122
Address: 2� Century Blvd., Ste. �00
  Nashville, TN 3�21�

www.boson.com/exsim-max-practice-exams
mailto:orgsales@boson.com
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